DEAR PEOPLE FROM THE FUTURE: Here's what we've figured out so far...

Welcome! This is a Q&A website for computer programmers and users alike, focused on helping fellow programmers and users. Read more

What are you stuck on? Ask a question and hopefully somebody will be able to help you out!
+3 votes

My girlfriend has a laptop where I recently installed Ubuntu (dual boot with Windows). The keyboard works at the grub menu screen, but when the system starts, sometimes it takes more than a minute for the keyboard to become responsive. Meanwhile, the trackpad works just fine. Sometimes it takes as little as 4 seconds (this is when the keyboard seems to work immediately), other times it's way over 40s (this is when the keyboard feels like it takes a long time for it to work).

What could be the cause of the delay? It's a laptop, so I cannot change the keyboard.


I never experienced anything like that (on Debian), so I'm a bit short of ideas. I don't think however that it's likely to be a hardware issue. You didn't mention if this happens with Ubuntu exclusively, or with Windows too. Do you see anything in the kernel logs (/var/log/messages)? Specifically, anything weird about USB or PS/2 controllers (i8042)? I would also try with a bootable Ubuntu USB-stick just to compare it with your own installation.
Even if it's a laptop, you can try plugging in an external USB keyboard. The laptop's own keyboard should also be connected to the USB bus unless it's an older model.
Another idea is an issue with so called "USB Legacy Support".


It doesn't happen on Windows. I'm going to try Debian and Fedora live CDs when I visit her. I'll also check the kernel logs. The laptop is an HP, and someone on Reddit reports the same issue with an HP laptop.


Does the PC work fine except for the keyboard? Or is it stalled until the keyboard is available?


It works fine except for the keyboard taking some time to work, sometimes it takes less time and sometimes more.


It sounds like there's some kind of problem with concurrent initialization of the devices. Meanwhile I've found a very similar bug report on launchpad. The workaround seems to be to play with the i8042.* kernel arguments. You should be able to change these settings directly from grub, by manually editing the command line. A list of all the available arguments is here. The bug report specifically mentions i8042.nopnp that seems to fix the issue, but you may want to try others too. Look however at the last comment where it mentions some HP Spectre models might not work (but there is a patch awaiting to be merged). I have an HP Pavilion myself and never experienced this issue.
I cannot make a better guess at what's going on. If you find a fix please answer your own question so that it's useful to others too.


I won't try the other distros, now that my issue has been solved. Now it takes very little time to load the keyboard (sudo dmesg):

[    3.272803] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input22

1 Answer

+3 votes

I fixed it by adding the i8042.nopnp kernel parameter to grub. Here's how to add kernel parameters via GRUB. This bug apparently affects only some HP keyboards on Ubuntu.

Contributions licensed under CC0